LaTeX Books


LaTeX Beginners Guide

Limited discount 50%
coupon code tDRet6Y

click here to read the whole story

LaTeX users online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 4 guests

glossaries | Package not found, but installed

LaTeX Forum: TeX Live and MacTeX

Add tags Information and discussion about TeX Live distribution for all platforms (Windows, Linux, Mac OS X) and the related MacTeX: installing, updating, configuring

Postby pyrogerg on Mon Aug 29th, 2011

Does anyone have an idea why I'd get the compiling error message "'glossaries.sty' not found" when Tex Live says that it is installed? The path to it appears to be appropriate (/usr/local/texlive/2011/texmf-dist/tex/latex/glossaries/base/glossaries.sty) and I'm not having trouble with other packages installed under Tex Live.

Thanks in advance.
Posts: 9
Joined: Fri Aug 12th, 2011

Postby localghost on Mon Aug 29th, 2011

Obviously it is not properly installed in the TeX installation tree. You can check that on the command line.
Code: Select all  •  Open in writeLaTeX
kpsewhich glossaries.sty

This should yield the complete path. If there is no output, the package is not installed correctly. Perhaps refreshment of the file name database as root on the command line by texhash does the trick.

LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes

¹ System: openSUSE 13.1 (Linux 3.11.10), TeX Live 2013 (vanilla), TeXworks 0.5 (r1351)
² Posting stopped indefinitely due to offenses
User avatar
Site Moderator
Posts: 9218
Joined: Fri Feb 2nd, 2007
Location: Braunschweig, Germany

Postby pyrogerg on Mon Aug 29th, 2011

Thanks for the suggestion. I did as you suggested and kspewhich won't return a path for glossaries.sty, unless I run kpsewhich from the directory in the Tex Live tree where glossaries.sty is located. I've run texhash and that did not fix the problem. What should I try next? I'm still very new to this, so I apologize if I'm missing something obvious.

I tried to uninstall and reinstall the glossaries package using the Tex Live package manager, but Tex Live refused to uninstall it, returning the following message.

tlmgr: not removing glossaries.x86_64-darwin, needed by glossaries

Posts: 9
Joined: Fri Aug 12th, 2011

Return to TeX Live and MacTeX

LaTeX users online

Users browsing this forum: No registered users and 4 guests