Featured Book

LaTeX Beginners Guide

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 1 guest

Partner Sites

TeXwelt - Fragen und Antworten goLaTeX
TeXblog
TeXnicCenter
TeXample

Kile keeps using TeX Live 2009 instead of 2011

Add tags Information and discussion about TeXLive distribution for all platforms; installation, administration; field reports

Kile keeps using TeX Live 2009 instead of 2011

Postby fpghost on Thu Oct 6th, 2011

Hi,

So after a clean installation of Ubuntu 11.04, I downloaded the web install-tl to install texlive 2011 doing a full installation following the instructions in the guide http://www.tug.org/texlive/doc/texli...#x1-170003.1.1

Installation went through fine and I added to my $HOME/.profile
PATH=/usr/local/texlive/2011/bin/i386-linux:$PATH; export PATH
MANPATH=/usr/local/texlive/2011/texmf/doc/man:$MANPATH; export MANPATH
INFOPATH=/usr/local/texlive/2011/texmf/doc/info:$INFOPATH; export INFOPATH


then restarted.

Now when I open the terminal and do 'tex' I see that I am using 2011 instead of the native 2009 shipped with the distro, great. I can compile .tex files and all the rest from the terminal. all seems to be good.

I try and compile something in Kile at this point, but it fails because of being unable to find .sty files (that are definitely in the 2011 texlive package) so I find this is strange and discovered when looking at the output that Kile is actually still using texlive 2009.....sigh....

Now I went back to the terminal as root and did echo $PATH and found that actually as root my PATH variable hadn't changed and when I ran tex at the terminal I got the 2009 verion, so thought maybe this had something to do with it, because perhaps it needed to update the PATH globally or something for Kile to recognise, so I went to etc/environment and added
PATH="/usr/local/texlive/2011/bin/i386-linux: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"


and went to etc/manpath.config and added
MANPATH_MAP /usr/local/texlive/2011/bin/i386-linux \
/usr/local/texlive/2011/texmf/doc/man


Now at the terminal running as root tex does show the 2011 version, great (This also means tlmgr runs in root at the terminal which is nice as before it only found tlmgr under user and wouldn't let me make changes to packages). However I try Kile again and nope, still attempting to use 2009.

OK, at this stage I'm totally confused and start googling, I find an article by someone who seems in a very similar situation to me except not ubuntu 11.04, http://theunspokenwords.net/blog/Inf...h-texlive-2011

The jist is that kile being a KDE application only sees the KDE environment variables so you need to go to the $HOME/kde folder create an env folder and make a file path.sh with the definitions contained in it. I think this is finally going to solve it for me, restart, hurriedly run Kile, but nope same errors again!
fpghost
 
Posts: 4
Joined: Thu Oct 6th, 2011

Re: Kile keeps using TeX Live 2009 instead of 2011

Postby fpghost on Thu Oct 6th, 2011

I next found the thread at http://ubuntuforums.org/showthread.p...t=texlive+2009 and this prompted mean to remove the PATH= lines I had previously added to my .profile and replace with (changing 2011 to 2009 and x86_64 with i386 etc):

# set PATH so it includes user's private bin if it exists if [ -d "$HOME/bin" ] ; then PATH="$HOME/bin:$PATH" fi if [ -d "/usr/local/texlive/2009/bin/x86_64-linux" ] ; then PATH="/usr/local/texlive/2009/bin/x86_64-linux:$PATH" fi if [ -d "/usr/local/texlive/2009/texmf" ] ; then export TEXMFMAIN="/usr/local/texlive/2009/texmf" fi if [ -d "/usr/local/texlive/2009/texmf-dist" ] ; then export TEXMFDIST="/usr/local/texlive/2009/texmf-dist" fi if [ -d "/usr/local/texlive/texmf-local" ] ; then export TEXMFLOCAL="/usr/local/texlive/texmf-local" fi if [ -d "$HOME/texmf" ] ; then export TEXMFHOME="$HOME/texmf" fi if [ -d "$HOME/.texlive2009/texmf-config" ] ; then export TEXMFCONFIG="$HOME" fi if [ -d "/usr/local/texlive/2009/texmf-config" ] ; then export TEXMFSYSCONFIG="/usr/local/texlive/2009/texmf-config" fi if [ -d "$HOME/.texlive2009/texmf-var" ] ; then export TEXMFVAR="$HOME" fi if [ -d "/usr/local/texlive/2009/texmf-var" ] ; then export TEXMFSYSVAR="/usr/local/texlive/2009/texmf-var" fi

Another restart, and another attempt at Kile, still no joy, but now a slightly
different error:

This is TeX, Version 3.1415926 (TeX Live 2009/Debian)
---! /usr/local/texlive/2011/texmf-var/web2c/tex/tex.fmt doesn't match tex.pool
(Fatal format file error; I'm stymied)

which at least seems to suggest even though it is still using 2009, it's searching for something in the right place

Anyone have an idea how I can resolve this and get Kile using 2011?
fpghost
 
Posts: 4
Joined: Thu Oct 6th, 2011

Re: Kile keeps using TeX Live 2009 instead of 2011

Postby mas on Fri Oct 7th, 2011

I do not use Kile. So, take my suggestions with caution.

Uninstall texlive from the distribution. IIRC, kile also will be removed. To prevent that you can create and install a texlive dummy package which prevents apt from removing it. Another alternative is to use TeXstudio (much similar to kile). TeXstudio, fortunately, does not depend on texlive packages of the distribution.

Set the path to TeX executables in the kile preferences. That will make kile use the ones you have installed.

Hope that helps.

Regards.

OS: Debian/GNU Linux; LaTeX System : TeXLive 2014; Editor : Vim
mas
 
Posts: 157
Joined: Thu Dec 4th, 2008

Re: Kile keeps using TeX Live 2009 instead of 2011

Postby fpghost on Fri Oct 7th, 2011

Hi, thanks very much for replying.

Uninstall texlive from the distribution.


Do you mean texlive 2009 or 2011, or both? and how do I remove these exactly? (I think I can remove 2011 by running tlmgr -gui and clicking unistall in one of menus, but not sure about removing the native 2009 if that's what you mean...how do I find the 'right' texlive in synaptic say)


IIRC, kile also will be removed. To prevent that you can create and install a texlive dummy package which prevents apt from removing it.


sorry, I'm relatively new to all this, how do I install a texlive dummy package?

Another alternative is to use TeXstudio (much similar to kile). TeXstudio, fortunately, does not depend on texlive packages of the distribution.


I tried TeXmaker and it worked fine, ran 2011 texlive found all .sty files etc, seems just a Kile issue.
Last edited by fpghost on Fri Oct 7th, 2011, edited 1 time in total.
fpghost
 
Posts: 4
Joined: Thu Oct 6th, 2011

Re: Kile keeps using TeX Live 2009 instead of 2011

Postby fpghost on Fri Oct 7th, 2011

I googled dummy package and kile, this looks promising http://texblog.net/latex-archive/linux/ ... 08-equivs/. Is that the kind of thing you mean?
fpghost
 
Posts: 4
Joined: Thu Oct 6th, 2011

Re: Kile keeps using TeX Live 2009 instead of 2011

Postby mas on Fri Oct 7th, 2011

Hi,

Do you mean texlive 2009 or 2011, or both? and how do I remove these exactly?


I meant TL-2009 that is installed on the system. Use synaptic, the package manager, to remove the installed packages. Let TL-2011 be on the system as that is better.

fpghost wrote:I googled dummy package and kile, this looks promising http://texblog.net/latex-archive/linux/ ... 08-equivs/. Is that the kind of thing you mean?


Yes. If you have problems creating a texlive dummy package, send me a private message. I will send it to you by email.

Regards.

OS: Debian/GNU Linux; LaTeX System : TeXLive 2014; Editor : Vim
mas
 
Posts: 157
Joined: Thu Dec 4th, 2008


Return to TeXLive

Who is online

Users browsing this forum: No registered users and 1 guest