Featured Book

LaTeX Beginners Guide

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 1 guest

Partner Sites

TeXwelt - Fragen und Antworten goLaTeX
TeXblog
TeXnicCenter
TeXample

Manual Package Installation (Linux Mint 12)

Add tags Information and discussion about TeXLive distribution for all platforms; installation, administration; field reports

Manual Package Installation (Linux Mint 12)

Postby munja72 on Fri Jan 6th, 2012

Hello,

I've used Kile 2.1 under Ubuntu. Manually macro package installing I made as following:

  1. copy package into gedit and save as packagename.sty
  2. put package in same named folder
  3. copy folder to /usr/share/texmf/tex/latex
  4. typ in terminal
    Code: Select all  •  Open in writeLaTeX
    $sudo mktexlsr
    , and that is it

Now I (try to) use Kile 2.1 under Linux Mint 12 and described procedure doesn't make any result. I'm bit confused, because Ubuntu and Mint are very similar distros. What I need to do for manually macro package installation in Linux Mint 12

thanks in advance
munja72
 
Posts: 2
Joined: Fri Jan 6th, 2012

Re: Manual Package Installation (Linux Mint 12)

Postby kaiserkarl13 on Fri Jan 6th, 2012

Your texmf may be in a different directory now. See what "texconfig" reports it to be (try the "rehash" option and take note of the directories it tries to use).

You could also put your packages in a subdirectory of your home directory (I call mine "texmf"), then use it like this: "mktexlsr $HOME/texmf" (which does not require root access, and thus is preferable). Many distributions also support TEXINPUTS, BSTINPUTS, and BIBINPUTS (environment variables), which can point to your own files. For example:
export TEXINPUTS=".:$HOME/LaTeX/includes:"
(put in $HOME/.bashrc or whatever your shell's startup file is). The leading "." says "search current directory first"; the trailing colon says "search system locations if you can't find it anywhere else."

I don't run Mint (I'm a Fedora user), but if you tell me which TeX distribution you're using (e.g., TeXLIVE), someone might be of more specific help.
kaiserkarl13
 
Posts: 566
Joined: Tue Mar 25th, 2008
Location: Knoxville, TN, USA

Re: Manual Package Installation (Linux Mint 12)

Postby munja72 on Sun Jan 8th, 2012

Hi,

I explore bit and I put my macro package folders to
Code: Select all  •  Open in writeLaTeX
/usr/share/texmf-telive/tex/latex

and type command above in terminal.

It is working!

Thanks for the help!
munja72
 
Posts: 2
Joined: Fri Jan 6th, 2012


Return to TeXLive

Who is online

Users browsing this forum: No registered users and 1 guest