LaTeX forum ⇒ MiKTeX and proTeXterror messages; \citation, \bibdata, \bibstyle commands

Information and discussion about MikTeX distribution for Windows and the related proTeXt: Installing, updating, configuring
adh2
Posts: 6
Joined: Wed May 05, 2010 4:30 pm

error messages; \citation, \bibdata, \bibstyle commands

Postby adh2 » Wed May 05, 2010 5:19 pm

Hi!
I'm entirely new here, so I hope I'm posting correctly in the correct forum now..
I have installed the ProTeX to my WinXP computer according to the interactive PDF, and everything appeared to work out fine during installation. But a problem occurs when I type the following in the editor window:

\documentclass{article}
\begin{document}
hello world
\end{document}

and select "build and view". First a PDF is created and opened in Acrobat, as it should. However, in the output window these messages are produced (I have omitted some of the pathways and replaced with dots, otherwise it's basically the exact text):

------------------------------------------------------------------------
----------------Output Profile: LaTeX => PDF-----------------
This is pdfTeX, Version 3.1415926-1.40.10 (MikTeX 2.8)
entering extended mode
("C:/... .../test1.tex")
LaTeX2e <2005/12/01>
Babel <v3.81> and hyphenation for enlish, dumylang, nohyphenation, german, ngerman, german-x-2009-06-19, ngerman-x-2009-06-19, french, loaded.
("C:\Program\MiKTeX 2.8\tex\latex\base\article.cls"
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
("C:\Program\MiKTeX 2.8\tex\latex\base\size10.clo")) ("C:\... ...\test1.aux")
[1{C:/... ... Application Data/MiKTeX 2.8/pdftex/config/pdftex.map)]
("C:\... ...\test1.aux") )<C:/Program/MiKTeX 2.8/fonts/type1/public/amsfonts/cm/cmr10.pfb>
Output written on test1.pdf (1page, 11905 bytes).
Transcript written on test1.log.
This is BibTeX, Versoin 0,99c (MiKTeX 2.8)
The top-level auxiliary file: C:\... ...\test1.aux
I found no \citation commands---while reading the file C:\.. .. ..\test1.aux
I found no \bibdata commands---while reading the file C:\.. .. ..\test1.aux
I found no \bibstyle commands---while reading the file C:\.. .. ..\test1.aux
(There were 3 error messages)
Couldn't find the input file C:\... ...\test1 nor C:\... ...\test1.idx
Usage: C:\Program\MikTeX 2.8\miktex\bin\makeindex.exe [-ilqrdgLT] [-s sty] [-o ind] [-t log] [-p num] [idx0 idx1 ...]

LaTeX-Result: 0 Erros(s), 0 Warning(s), 0 Bad Box(es), 1 Page(s)
-------------------------------------------------------------------------

I don't understand what the parts about \citation, \bibdata, \bibstyle commands mean? I guess it's not really supposed to be this way, right?

I have searched the forums and other info-sources but didn't find anything that could help me.
So any help would be very much appreciated!
Best regards,
Alfred

Link:
BBcode:
HTML:
Hide post links
Show post links

josephwright
Site Moderator
Posts: 813
Joined: Tue Jul 01, 2008 2:19 pm
Contact:

Postby josephwright » Wed May 05, 2010 7:01 pm

The "build and view" script is running LaTeX, BibTeX and MakeIndex. You don't actually need BibTeX or MakeIndex (you have no citations or index data), and so the two programs are issuing warnings. However, you can safely ignore these. If you tell us which editor you use, we will be able to tell you how to run LaTeX on its own, so there are no unnecessary messages.
Joseph Wright

Link:
BBcode:
HTML:
Hide post links
Show post links

adh2
Posts: 6
Joined: Wed May 05, 2010 4:30 pm

Postby adh2 » Wed May 05, 2010 10:27 pm

OK, thank you!
I use TeXnicCenter.

Link:
BBcode:
HTML:
Hide post links
Show post links

Phanixis
Posts: 7
Joined: Mon Sep 15, 2008 6:53 pm

Postby Phanixis » Wed Nov 02, 2011 4:49 pm

I am suffering from the same problem, but using Winedt. Problem is, the error messages OP mentioned are given as errors, not warnings, so I cannot compile documents at all.

Any help would be appreciated.

Thanks.

Link:
BBcode:
HTML:
Hide post links
Show post links


Return to “MiKTeX and proTeXt”

Who is online

Users browsing this forum: No registered users and 2 guests