Featured Book

LaTeX Beginners Guide

Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 3 guests

Partner Sites

TeXwelt - Fragen und Antworten goLaTeX
TeXblog
TeXnicCenter
TeXample

beamer | Two Columns with Pictures uncovered Item by Item

Add tags Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.

beamer | Two Columns with Pictures uncovered Item by Item

Postby apos on Sun Jan 22nd, 2012

Hi there,

I am here under Ubuntu 11.10 with LyX 2.x and beamer class (options:
"t").

I am trying to create a frame with the following content:

* itemized text on the left side
* corresponding picture on the right
* realized with two column layout

And here's the problem: the pictures on the right should be NOT visible
until its their turn in the "item"-environment!

I tried to realize it like this:

Code: Select all  •  Open in writeLaTeX
Frame Begin
       
Lyx -> Column environment
       
   Lyx -> Column: 6 cm
      * <1->first text left
     * <3->second text left
       
   Lyx -> Column: 4 cm
     * <2->[first picture]
     * <4->[second picture]
       
Frame End


Auswahl_002.png
LyX Frame
Auswahl_002.png (40.84 KiB) Viewed 3384 times


The pictures are inserted "plain", whith the "insert graphics" command.
But the pictures are shown and visible all the time ... !

Auswahl_003.png
PDF with picture alredy showing
Auswahl_003.png (52.89 KiB) Viewed 3384 times


Dealing with this problem for several days now, I found a - pur tex -
solution at
http://www.informatik.uni-freiburg.de/~ ... -3_en.html
(there the beamer class example 5).

Its pretty much what I like (beside the overwrite), but it won't work in
LyX with the method above. OK, I could write plain TeX-code, but - hey -
we like to work with the LyX environment ;)

So there are my questions according to beamer, LyX and this problem

1. How to "itemize" pictures correctly?
2. How toggle the visibility of pictures in LyX within a column
environment (more generally)
3. How to avoid an item environment in (get rid of the icons) LyX AND use <1>, <1->, ...
(like in the example mentioned above)
4. Is there a Documentation for LyX / Beamer (I only can find one
for "foiles")

People, you will help me a lot, within a few days there is an important
presentation ;)

I posted this question also at lyx-users mailing list. I am showing up a solution here and there, a soon as I know how to solve the problem.

Greets
Axel
User avatar
apos
 
Posts: 3
Joined: Sun Jan 22nd, 2012
Location: Wiesbaden, Germany

Re: beamer | Two Columns with Pictures uncovered Item by Ite

Postby Stefan_K on Sun Jan 22nd, 2012

Hi Axel,

welcome to the board!

With LyX it's often hard to explain a problem and to describe a possbible solution, because it may involve clicking somewhere in a GUI that changes, and code is hidden. With LaTeX, it's often just exchanging code: posting the problem code, getting back the fixed code.

apos wrote:within a few days there is an important
presentation


If it's really important, perhaps produce also LaTeX presentation, to avoid LyX-only problems, to have a higher chance to achieve the desired layout in time.

Stefan
LaTeX Community Administrator
User avatar
Stefan_K
Site Admin
 
Posts: 6269
Joined: Mon Mar 10th, 2008
Location: Hamburg, Germany

Re: beamer | Two Columns with Pictures uncovered Item by Ite

Postby apos on Sun Jan 22nd, 2012

Thanks Stefan for your reply,

welcome everybody. I am working with LyX since its early beginnings, and that's really for a long time. But to the beamer class I am relatively new.

For my problem: I found the solution for one of my problems, only one question is left (see at the end of the post). Your posting made me look again in the preamble, commenting things out step by step and beginning from scratch.

The mean person was this option :mrgreen:
Code: Select all  •  Open in writeLaTeX
\setbeamercovered{transparent}

Commenting it out, and everything went like expected. Mean mean mean ... I mean, really mean ;)

For anyone of you, who likes to have the LyX-code for the - now working - sample posted in the first thread, here it is (be aware this is LyX 2.0!):

Code: Select all  •  Open in writeLaTeX
#LyX 2.0 created this file. For more info see http://www.lyx.org/
\lyxformat 413
\begin_document
\begin_header
\textclass beamer
\begin_preamble
\usetheme{Marburg} % nice, outline on right
\beamerdefaultoverlayspecification{<+->}
\end_preamble
\options t
\use_default_options true
\maintain_unincluded_children false
\language ngerman
\language_package default
\inputencoding auto
\fontencoding global
\font_roman default
\font_sans default
\font_typewriter default
\font_default_family default
\use_non_tex_fonts false
\font_sc false
\font_osf false
\font_sf_scale 100
\font_tt_scale 100

\graphics default
\default_output_format default
\output_sync 0
\bibtex_command default
\index_command default
\paperfontsize default
\spacing single
\use_hyperref false
\pdf_bookmarks true
\pdf_bookmarksnumbered true
\pdf_bookmarksopen true
\pdf_bookmarksopenlevel 1
\pdf_breaklinks false
\pdf_pdfborder true
\pdf_colorlinks true
\pdf_backref false
\pdf_pdfusetitle true
\papersize a4paper
\use_geometry true
\use_amsmath 1
\use_esint 0
\use_mhchem 1
\use_mathdots 1
\cite_engine natbib_authoryear
\use_bibtopic false
\use_indices false
\paperorientation portrait
\suppress_date false
\use_refstyle 0
\index Stichwortverzeichnis
\shortcut idx
\color #008000
\end_index
\leftmargin 6cm
\topmargin 1.5cm
\rightmargin 2cm
\bottommargin 2.5cm
\headheight 1cm
\headsep 1cm
\footskip 1cm
\secnumdepth 2
\tocdepth 2
\paragraph_separation indent
\paragraph_indentation default
\quotes_language german
\papercolumns 1
\papersides 1
\paperpagestyle default
\tracking_changes false
\output_changes false
\html_math_output 0
\html_css_as_file 0
\html_be_strict false
\end_header

\begin_body

\begin_layout BeginFrame
test1
\end_layout

\begin_layout ColumnsTopAligned

\end_layout

\begin_deeper
\begin_layout Column
6cm
\end_layout

\begin_layout Itemize
<1->first text
\end_layout

\begin_layout Itemize
<3->second text
\end_layout

\begin_layout Standard
\begin_inset space \hspace{}
\length 6cm
\end_inset


\end_layout

\begin_layout Column
4cm
\end_layout

\begin_layout Itemize
\begin_inset ERT
status open

\begin_layout Plain Layout

<2->
\end_layout

\end_inset


\begin_inset Graphics
        filename pics/Java.jpg
        lyxscale 20
        height 1.5cm

\end_inset


\end_layout

\begin_layout Itemize
\begin_inset ERT
status open

\begin_layout Plain Layout

<4->
\end_layout

\end_inset


\begin_inset Graphics
        filename pics/SpringSourceVM-logo.png
        lyxscale 20
        height 1.5cm

\end_inset


\end_layout

\end_deeper
\begin_layout EndFrame

\end_layout

\begin_layout BeginFrame
test2
\end_layout

\begin_layout ColumnsTopAligned

\end_layout

\begin_deeper
\begin_layout Column
4cm
\end_layout

\begin_layout Itemize
<1-> Lorem ipsum dolor sit amet, consectetur adipisicing elit
\end_layout

\begin_layout Itemize
<3-> Lorem ipsum dolor sit amet, consectetur adipisicing elit
\end_layout

\begin_layout Itemize
<5-> Lorem ipsum dolor sit amet, consectetur adipisicing elit
\end_layout

\begin_layout Standard
\begin_inset space \hspace{}
\length 4cm
\end_inset


\end_layout

\begin_layout Column
4cm
\end_layout

\begin_layout Standard
\begin_inset ERT
status open

\begin_layout Plain Layout


\backslash
begin{overprint}
\end_layout

\begin_layout Plain Layout


\backslash
includegraphics<2>{pics/go-next.pdf}
\end_layout

\begin_layout Plain Layout


\backslash
includegraphics<4>{pics/go-next.pdf}
\end_layout

\begin_layout Plain Layout


\backslash
includegraphics<6>{pics/go-next.pdf}
\end_layout

\begin_layout Plain Layout


\backslash
end{overprint
}
\end_layout

\end_inset


\end_layout

\end_deeper
\begin_layout EndFrame

\end_layout

\end_body
\end_document


The only remaining problem now is:
  • avoiding an itemize-environment AND use <1->,<2->, ...
  • using the overprint environment in LyX

Concrete: how to do the following in LyX:

Code: Select all  •  Open in writeLaTeX
\begin{overprint}
\includegraphics<2>{PIC1}
\includegraphics<4>{PIC2}
\includegraphics<6>{PIC3}
\end{overprint
}


I think, sometimes I will write a handbook for the beamer class ;) This is a really really missing peace.

Thanks
Axel
User avatar
apos
 
Posts: 3
Joined: Sun Jan 22nd, 2012
Location: Wiesbaden, Germany

Re: beamer | Two Columns with Pictures uncovered Item by Ite

Postby Stefan_K on Sun Jan 22nd, 2012

Hi Axel,

thanks for posting the solution!

It' nice to read that you are an experienced LyX user. It would be great if you would like to look at LyX questions here, from time to time, as LyX experts are rare.

When I look into the LyX subforum, I see many still open questions. So it would be great to have a helping hand there.

Stefan
LaTeX Community Administrator
User avatar
Stefan_K
Site Admin
 
Posts: 6269
Joined: Mon Mar 10th, 2008
Location: Hamburg, Germany

Re: beamer | Two Columns with Pictures uncovered Item by Ite

Postby apos on Sun Jan 22nd, 2012

You're welcome, I am sure you will see me in this forum.

This forum is a good place to post, I don't remember that I recovered it's precence in former times. I don't really like the mailing lists due to their limitations when it comes to the presentation of a problem (visually). Although there is a good blog interface for gmane (lyx-users mailing list), but nevertheless, it will remain "email" format. But that's another discussion (please don't comment here ... :mrgreen: ).
User avatar
apos
 
Posts: 3
Joined: Sun Jan 22nd, 2012
Location: Wiesbaden, Germany


Return to LyX

Who is online

Users browsing this forum: No registered users and 3 guests