Featured Book

LaTeX Beginners Guide

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 5 guests

Partner Sites

TeXwelt - Fragen und Antworten goLaTeX
TeXblog
TeXnicCenter
TeXample

Citations not appearing and causing Errors

citingjurabibLyXAdd tags Information and discussion about LyX, a WYSIWYM editor, available for Linux, Windows and Mac OS X systems.

Citations not appearing and causing Errors

Postby thmbbs on Wed Mar 20th, 2013

Hi,

I should have been here much more earlier, not at the moment of no return, but things seemed to be going smooth and I was able to write the bulk of my thesis on LyX and I thought it will end that way. With the whooshing sound of the deadline in my ears, I am desperately looking for your help.

I am trying to insert citations in jurabib style and as a matter of fact, after plethora of errors and some intuitive tweaking at the moment I ended up with a "?" sign where the citation should have been.

Since, I am a newbie/fool I won't be able to provide details. Instead, I will beg your help by sharing my files.

This is my utterly hopeless thesis:
Haydi3.lyx
(117.82 KiB) Downloaded 42 times


This is my .bib file that I got through Zotero, output format is BibTeX:
upload.bib
(15.23 KiB) Downloaded 34 times

Lastly, this all the installed packages filtered by the word "latex":
packages-installed.png
packages-installed.png (207.84 KiB) Viewed 721 times

I can give my left kidney for help.

Thank you and hi again...
Last edited by localghost on Wed Mar 20th, 2013, edited 1 time in total.
Reason: Preferably no external links (see Board Rules). Attachments go onto the forum server where possible.
thmbbs
 
Posts: 1
Joined: Wed Mar 20th, 2013

Re: Citations not appearing and causing Errors

Postby kaiserkarl13 on Sun Mar 24th, 2013

I found no citation commands in your entire document (I'm not counting the \nocite{*} I found at the end). When I added some, they came out in fairly standard form, e.g., [1].

If you get question marks, it might mean you've made a typo, or it might mean you need to run LaTeX again. Since you're using LyX, though, it should handle that sort of thing for you.

As I said, this works for me (once I download the subscript package, anyway), if I add in some citation commands, either through LyX or through LaTeX.
kaiserkarl13
 
Posts: 566
Joined: Tue Mar 25th, 2008
Location: Knoxville, TN, USA


Topic Tags

citingjurabibLyX

Return to LyX

Who is online

Users browsing this forum: No registered users and 5 guests