LaTeX users online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 4 guests

Inverse Search with Sumatra PDF and TeXnicCenter Topic is solved

LaTeX Forum: General

SumatraTeXnicCenterviewersAdd tags General information and discussion about TeXnicCenter

Postby TexUser12 on Mon Feb 11th, 2013

Hi,

I am trying to use Sumatra PDF with TeXnicCenter (TXC) 2.0 Beta 1 (x64) on a Windows 7 distribution. I read several related topics on this forum but could not find an answer to my quite usual problem: I do not manage to obtain an inverse search. Forward search is working fine though. Here are the parameters of my current profile.

(La)TeX
Path to the Latex compiler
C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\pdflatex.exe
Command Line to pass to the Latex compiler
-synctex=-1 -max-print-line=120 -interaction=nonstopmode "%wm"

Bibtex
C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\bibtex.exe
Command Line for Bibtex
"%tm"

Make index
C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\makeindex.exe
Command line to Makeindex
"%tm.idx" -t "%tm.ilg" -o "%tm.ind"

Viewer
C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto(’%f’,’%l’)]\""
View Project output (DDE command)
[Open("%bm.pdf",0,1,1)]
Forward Search
[ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)]

I tried several things, included putting the current TXC repository at another location. Neither "Program Files" or "Program Files (x86)" works. I assumed the space in the root is the cause of the problem. Yet, when I do not put it inside "Program Files" or "Program Files (x86)", I cannot manage to open my source files with TXC (the explorer does not recognize it as an executable program apparently).

Any help is welcome.
Thanks
TexUser12
 
Posts: 4
Joined: Mon Feb 11th, 2013

Postby ralfinho on Thu Feb 21st, 2013

Hallo TeXUser12,

apparently you are using a 32bit Miktex (your path to Miktex shows Program Files (x86)). I haven't tried this, but I'm using Miktex 64bit and Inverse Search works.
But Ihave to admit, that I haven't controlled all your lines in detail, so of course there can be another fault.

Greets ralfinho
ralfinho
 
Posts: 6
Joined: Fri Jan 4th, 2013

Postby MartinC on Fri Feb 22nd, 2013

You need to set inverse search in sumatrapdf. See:

http://www.latex-community.org/forum/vi ... 32&t=10188
MartinC
 
Posts: 152
Joined: Wed Jan 17th, 2007

Postby TexUser12 on Wed Feb 27th, 2013

Thank you very much !! It works now. Indeed, I forgot to change the setting of Sumatra.

I would have another question. My correct setting in Sumatre is now :
"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe" /ddecmd "[goto('%f', '%l')]"
But, each time I open a new tex file and compile it with Sumatra, this setting is changed. I have to put back the correct command each time. Do you know a way to make it remember this setting ?

Thanks a lot.
TexUser12
 
Posts: 4
Joined: Mon Feb 11th, 2013

Postby MartinC on Wed Feb 27th, 2013

Ah sorry, I hadn't seen that it was already set in your "Viewer" configuration. The problem with the line:

C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto(’%f’,’%l’)]\""


in your viewer configuration is that your apostrophes are wrong. Just change them from ’ to ' and everything should be alright.
MartinC
 
Posts: 152
Joined: Wed Jan 17th, 2007

Postby TexUser12 on Wed Feb 27th, 2013

Ok, so with the following "Viewer" configuration
C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe" /ddecmd\ "[goto('%f', '%l')]\"
I still have an error.

But if I just define the inverse search in Sumatra, it works, so I am just gonna stand with this configuration.

Thanks for your help.
TexUser12
 
Posts: 4
Joined: Mon Feb 11th, 2013

Postby MartinC on Thu Feb 28th, 2013

Check your spelling, you did not type exactly the same as this:

C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\""

Copy and paste this expression and it should work.
MartinC
 
Posts: 152
Joined: Wed Jan 17th, 2007

Postby TexUser12 on Thu Feb 28th, 2013

Indeed. Thanks a lot !
TexUser12
 
Posts: 4
Joined: Mon Feb 11th, 2013


Topic Tags

SumatraTeXnicCenterviewers

Return to General

LaTeX users online

Users browsing this forum: No registered users and 4 guests