LaTeX forum ⇒ GeneralTexnicCenter Package Download

General information and discussion about TeXnicCenter
creuvette
Posts: 5
Joined: Wed May 30, 2007 11:42 am

TexnicCenter Package Download

Postby creuvette » Wed May 30, 2007 1:42 pm

Hi!

I've got a problem concerning the package download of texniccenter. Normally, when you've got a new package which is not already installed, texniccenter downloads it automatically. In my case, this does not work - texniccenter does not even try to connect to the internet.

What can I do?

Thanks for your help!!

creuvette

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
countbela666
Posts: 64
Joined: Thu Apr 26, 2007 2:44 pm
Location: Berlin, Germany

Postby countbela666 » Wed May 30, 2007 2:06 pm

Hi,

if installed properly TeXnicCenter usually invokes MiKTeX to install missing packages. You can enable your MiKTeX distribution to do so in the "General" tab of the MiKTeX options dialog (run mo.exe from the prompt) by choosing "Yes" or "Ask me first" for the value "Install missing packages on-the-fly".

Regards
Marcel
Listen to me children of the night, beyond the doors of darkness you will find
a thousand worlds for you to see here, take my hand and follow me...

Link:
BBcode:
HTML:
Hide post links
Show post links

creuvette
Posts: 5
Joined: Wed May 30, 2007 11:42 am

Postby creuvette » Wed May 30, 2007 4:11 pm

Hey Marcel!

Thanks! It has not worked anyway.
Do I have to indicate something special when installing texniccenter? like "using Miktex" or something?

creuvette

Link:
BBcode:
HTML:
Hide post links
Show post links

mcostolo
Posts: 1
Joined: Mon Jun 04, 2007 3:13 pm

Postby mcostolo » Mon Jun 04, 2007 3:19 pm

I have also just installed 1 Beta 7.01. I have quite a few LaTeX classes in the MiKTeX directory structure that aren't found by TexnicCenter and so it wants to go and download them again. I can't find any way to configure TexnicCenter so that it uses the class files that MiKTeX already knows about. I'll admit this is rather confusing as WinEdt/MiKTeX seems to find them just fine.

Is this just a bug in the Beta version or is there some configuration file I don't know about?

Thanks,

-Mike-

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Mon Jun 04, 2007 5:47 pm

This is not a problem of TeXnicCenter (or any other editor), because it only executes the (pdf)latex binaries to compile the document. You do not write whether you installed these classes manually or with the MikTeX Package Manager (MPM). Since you are not sure if the combination WinEdt/MikTeX works fine, you should refresh the file name database (FNDB) via MikTeX Settings or do that manually on the console. Your added classes should be found then.
  1. texhash
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 13.1 (Linux 3.11.10), TeX Live 2013 (vanilla), TeXworks 0.5 (r1351)
² Posting stopped indefinitely due to offenses

Link:
BBcode:
HTML:
Hide post links
Show post links

toultoutim
Posts: 2
Joined: Tue Jun 05, 2007 12:05 am

Postby toultoutim » Tue Jun 05, 2007 8:46 am

Hi, I 've got a problem slightly different but quite alike the one creuvette has described ( this is why I don't create a new post)
I'm trying to use the babel package with the [frenchb] option in the following way :

\documentclass{article}
\usepackage[frenchb]{babel}
...

When I compile the doc Texnic tries to connect the Internet to download some composant, but nothing happens at all ...

moreover I've checked the Miktex installation of the babel package and it is complete so I don't understand why Texnic tries do download anythng at all it's already on my computer...

please help I would Like to use accent without always typing things like \'e etc...

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
localghost
Site Moderator
Posts: 9206
Joined: Fri Feb 02, 2007 12:06 pm
Location: Braunschweig, Germany

Postby localghost » Tue Jun 05, 2007 4:55 pm

Again the question for the used MiKTeX system. And are you sure that the option frenchb is supported by the babel package? I couldn't find any hints in its documentation.
LaTeX Community Moderator
How to make a "Minimal Example"
Board Rules
Avoidable Mistakes


¹ System: openSUSE 13.1 (Linux 3.11.10), TeX Live 2013 (vanilla), TeXworks 0.5 (r1351)
² Posting stopped indefinitely due to offenses

Link:
BBcode:
HTML:
Hide post links
Show post links

debro5
Posts: 2
Joined: Tue May 22, 2007 5:39 pm

Postby debro5 » Wed Jun 06, 2007 4:29 am

You must replace:

\usepackage[frenchb]{babel} by

\usepackage[francais]{babel}

frenchb not maintained anymore

Link:
BBcode:
HTML:
Hide post links
Show post links

toultoutim
Posts: 2
Joined: Tue Jun 05, 2007 12:05 am

Postby toultoutim » Wed Jun 06, 2007 8:54 am

thank's for your answers as a matter of fact, the package Latin Modern was missing and this was why things didn't worked.

The fact that babel package was well installed, was what has made me wonder "why the hell Evil or Very Mad doesn't it work?"

Link:
BBcode:
HTML:
Hide post links
Show post links

banana_inc
Posts: 2
Joined: Mon Dec 28, 2009 2:47 pm

Postby banana_inc » Mon Dec 28, 2009 2:50 pm

Hello creuvette!

I had the same problem, finally it appears that there is an incompatibility with miktex and texniccenter... To solve the problem you must allow Miktex to download missing packages without asking first. See the page http://miktex.org/2.8/issues

Hope it will solve your problem as it solved mine!

Link:
BBcode:
HTML:
Hide post links
Show post links


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest