Featured Books


Preorder discount 35%
coupon code LXCB35

LaTeX Beginners Guide

Limited discount 50%
coupon code tDRet6Y

click here to read whole story

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 2 guests

glossaries | Problem with non-standard Page Numbering Topic is solved

glossariesAdd tags Information and discussion about MakeIndex - the tool to generate subject indices for LaTeX documents.

glossaries | Problem with non-standard Page Numbering

Postby toms125 on Fri Feb 1st, 2013


I am using the glossaries package in my report document using TeXworks.

I have created a new glossary "List of Symbols" that I am trying to display inside chapters with \printglossaries. If I use a classic page numbering like roman or arabic, the "List of Symbols" will contain all the symbols that are used with the command \gls{} or added with \glsadd{} or \glsaddall{}, which is fine.

However, when I redefine the page numbering to have chapter-page, the commands listed above don't add anymore the symbols to the "List of Symbols", which is therefore empty. The symbols are added only if the commands like \gls{} are used before redefining the page numbering.

Here is a minimal example of my code:
Code: Select all  •  Open in writeLaTeX

\newglossary[slg]{symbols}{sym}{sbl}{List of Symbols}
description=random symbol}


%Redefining the page numbering for chapters

\chapter{Chapter 1
%The list of symbol is empty...


If I don't redefine the page numbering for chapters, the symbol is printed in the "List of Symbols" but with this code it is not.

Does anyone have a solution for this?

Thank you!
Posts: 5
Joined: Fri Feb 1st, 2013

Re: glossaries | Problem with non-standard Page Numbering  Topic is solved

Postby nlct on Sun Feb 3rd, 2013

You need to change the page compositor to - (hyphen), since your locations are hyphen-separated numbers:
Code: Select all  •  Open in writeLaTeX

This must come before \makeglossaries. (You have to set the compositor even if you've used the nonumberlist option.)

Nicola Talbot
User avatar
Posts: 258
Joined: Thu Nov 6th, 2008

Topic Tags


Return to MakeIndex, Nomenclature, Glossaries and Acronyms

Who is online

Users browsing this forum: No registered users and 2 guests