LaTeX Books


LaTeX Beginners Guide

Limited discount 50%
coupon code tDRet6Y

click here to read the whole story

LaTeX users online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 1327 on Tue Nov 05, 2013 7:11 pm

Users browsing this forum: No registered users and 4 guests

pdfcrop: The Perl script could not be found.

LaTeX Forum: MiKTeX and proTeXt

Add tags Information and discussion about MikTeX distribution for Windows and the related proTeXt: Installing, updating, configuring

Postby Ede_123 on Thu Aug 18th, 2011


I have a problem concerning pdfcrop.

When I call pdfcrop from commandline I get the following error:
Code: Select all  •  Open in writeLaTeX
pdfcrop: The Perl script could not be found.
pdfcrop: Data: scripts/pdfcrop/perl/

I'm using Windows7 x64, Miktex 2.9 (x86) and I installed Active Perl (x86).
The following files are present in my miktex installation:
C:\Program Files (x86)\TeX\MiKTeX 2.9\miktex\bin\pdfcrop.exe
C:\Program Files (x86)\TeX\MiKTeX 2.9\scripts\pdfcrop\

I also tried copying to
C:\Program Files (x86)\TeX\MiKTeX 2.9\scripts\pdfcrop\perl\
but it didn't change anything.

My PATH varialbe contains:
C:\Program Files (x86)\Perl\site\bin
C:\Program Files (x86)\Perl\bin
C:\Program Files (x86)\TeX\MiKTeX 2.9\miktex\bin

I allready tried calling the perl script directly. It works but produces another error (probably due to some path error)

Does anyone have an idea what's wrong with my setup of pdfcrop?
Last edited by Ede_123 on Fri Aug 19th, 2011, edited 1 time in total.
Posts: 5
Joined: Tue Jan 25th, 2011

Postby Ede_123 on Thu Aug 18th, 2011

Ok, I successfully broke pdfcrop on my laptop were it used to work before.
What I did was an update of MikTeX today. Yesterday everything worked ok...

Is there somebody who could assist me in locating the origin of the problem? Since I'm not too familiar with the internal structure of LaTeX it's quite complicated for me to track down what package update broke pdfcrop for me.

I assume first step would be to find what packages got updated and what version they were before. Is there a logfile somewehere, where the updates are written to?

Update 2:
Okay, I did it! pdfcrop is working again.

Problem seems, that pdfcrop.exe actually searches for in
MiKTeX 2.9/scripts/pdfcrop/perl/
but after the pdfcrop update to v1.32 from 2011/08/10 ist is just written to
MiKTeX 2.9/scripts/pdfcrop

My approach to copy into the subfolder /perl didn't work in the first place because I forgot to refresh file name database. (MiKTeX Options -> Refresh FNDB)

I'm going to refer this thread to Heiko Oberdiek, pdfcrops author. I assume he knows what to do, to resolve this problem in future versions.

Update 3:
Since it's probably an issue with MiKTeX and not with pdfcrop itself I created a bugreport here: ... tid=110783
Posts: 5
Joined: Tue Jan 25th, 2011

Postby Stefan_K on Thu Aug 18th, 2011

Thanks for the updates!

LaTeX Community Administrator
User avatar
Site Admin
Posts: 7239
Joined: Mon Mar 10th, 2008
Location: Hamburg, Germany

Postby Ede_123 on Fri Aug 19th, 2011

The bug has been fixed. The fix will be made available with the
next update cycle. You can watch the MiKTeX project page
for further information on the next update.

(From ... tid=110783)
Posts: 5
Joined: Tue Jan 25th, 2011

Return to MiKTeX and proTeXt

LaTeX users online

Users browsing this forum: No registered users and 4 guests